Edi`s Seite für historische Rundfunktechnik

Seite
Menü
News
Sie sind hier:   Startseite > Restauration Meßtechnik > Restauration 600V 0,2A- Stromversorgungsgerät Statron 4210 von 1984

Restauration 600V 0,2A- Stromversorgungsgerät Statron 4210 von 1984
(Fotoserie unten)


Statron Netzteil 4210, 600 V/ 0,2 A


Restaurationsbericht
(über 4 Tage erstellt)

Ich habe ein Statron 4210- und sitze seit Tagen ergebnislos daran- arge
Probleme- es kommt fast nichts raus (10V).

Die 4 Steckbaugruppen sind vermutlich ok, sie funktionieren im Statron
4209 (3KV/0,2A !), welches die gleichen Baugruppen- mit wenigen
Änderungen auf den Platinen- verwendet. Ich kann den Satz komplett
tauschen, 4209 funktioniert, 4210: ändert wenig.

Die Schaltung des Grundgeräts (Chassis) ist ebenfalls nahezu gleich.
Gleichrichtung, Thyristor- Phasenanschnitt, Längsregel- Transi... ok.

Ich kann den Phasenanschnitt auf vollen Wert bringen, dann volle Ua.
Dann ist die Steuerung des Treibers zum Längsregler jedoch außer
Betrieb, und selbst, wenn ich eine Ersatzlast biete, kenne ich nicht die
Werte.
Den Phasenanschnitt kann ich mit dem Grund- Einsteller etwas aufdrehen-
aber... keine Regelung.

Die Einstellung von Strom und Spannung bewirken 2 Operationsverstärker
A109 (DDR- Typ von µA709), diese steuern den Thyristor- Phasenanschnitt
und den Längsregeltransi.

Ich fand bei der Fehlersuche sogar Fehler und undokumentierte Änderungen
in den Unterlagen von 4209 u. 4210, habe diese inzwischen berichtigt,
die Schaltungen mit Bildbearbeitung neu aufgesetzt, und mache diese
gerade druckfertig.

Ich habe das Gerät schon seit den 90er Jahren, ich weiß nicht mehr, ob
es beim Erwerb funktionstüchtig war.
Spuren von Vor- Reparaturen sind erkennbar.

Ich gehe davon aus, daß möglicherweise eine undokumentierte Beschaltung
oder eine Verschaltung bei vorherigen Reparaturversuchen vorliegt.

Hilfreich wären unbedingt Angaben von Spannungen/ Strömen im
Betriebsfall, etwa bei einer definierten Ausgangsspannung, eben an
verschiedenen Punkten der 2 Regelungen.
Ja, es sind 2 miteinander gekoppelte Regelungen !

Vielleicht gibt es auch Hinweise in Unterlagen zur Trennung der
Regelungen zwecks Überprüfung/ Einstellung.

Ich habe die Betriebsanleitungen und Schaltpläne von 4 Statron- Geräten
dieser Bauart. Die sind eigentlich fast voneinander kopiert. Die
Beschreibung ist sehr kurz, und keine Hilfe.

***********************************

Ich denke, der Fehler wird mit Logik zu finden sein.
Zumindest ist in EINEM Schaltplan der Serie eine handgekritzelte
Eintragung für die Uce- Einstellung des dicken Regeltransis drin ("SV"-
Baugruppe)- die schon mal einen Anhaltswert liefert, den diese ist eine
Regelgröße.
Da 5 Geräte die 4 Steckbaugruppen mit gleicher Halbleiterbestückung
verwenden, sind viele Spannungswerte in gleicher Höhe zu erwarten.

Ich habe getrickst, die Anlaufhilfe (RC- Brücke über den Steuer-
Thyristoren) vergrößert, um erst mal etwas höhere Spannungen an den
Längsregler zu bekommen, "damit der was zum Regeln hat"-
Und festgestellt, daß sich die Uce des Längsreglertransis mit den
Spannungs- Strom- Stellern zwar -in Grenzen- ändert, die OPV's also
arbeiten, aber die primärseitige Thyristor- Ansteuerung jedoch nicht
angeworfen wird, die Regelung via Phasenanschnitt also gar nicht greift.

Die Änderung in Grenzen ist logisch, da die OPV's nur einen Teil regeln,
hauptsächlich wird der Netztrafo mit der Phasenanschnittsteuerung auf
Ausgangsspannung + Uce des Längsreglers + Spannung über Meßwiderstand
gebracht, die OPV's regeln den Rest aus.

Wie geschrieben, ich kann den Phasenanschnitt per Hand an den
Steuertransis der SV- Baugruppe selbst auslösen- sieht aus, als bekommt
diese Steuerung nicht das am Eingang, was dorthin gehört.

***********************************
Ich besitze die Pläne des Statron 4210, ich bekam die Unterlagen vor einigen
Jahren noch als Scans von Statron zugeschickt !

Ich habe nun die Pläne korrigiert und restauriert, undokumentierte Änderungen vermerkt.

Bearbeitung weil: Fremd- Scans sind meist von lausiger Qualität,
herunterkomprimiert "bis zur Kotzgrenze", und die Papier- Unterlagen, die
ich habe, sind geknickt, angegilbt, angerissen, verschmaddert, eben alte
Sachen, Werkstattgebrauch.

Wer so ein Gerät hat, ich kann die Unterlagen in guter Qualität als
PDF's zur Verfügung stellen, ich bin noch am Erstellen der PDF's.

***********************************

Zur Funktion, wie ich sie bisher ermitteln konnte:

Beim Einschalten geht erst mal über W4/ C3, die die Thyristoren
überbrücken, etwas Speisung in den Trafo, sonst wäre ja hinter dem Trafo
alles tot, und was sollte dann die Zündung der Thyris auslösen.

Es existieren dann:
1. Die Rohspannung nach dem Gleichrichter,
2. Die Spannung hinter dem Längsregler und
3.Die Spannung an den Ausgangsklemmen.

Diesegehen dann über die Treiberplatine zur Regelverstärkerplatine (OPV), Stromversorgung (SV).

Die 2. Spannung ist auch als Bezug an der Steuerplatine.

Bezug ist also + Ub = 0- 600V.

Minus ist nicht Bezug, und nicht von Hause aus Masse, kann  aber an die
Gerätemasse gelegt werden- dies hat aber keinen Einfluß auf die
Funktionen.

Die Steuer-- Platine zündet die Thyristoren zu einem bestimmten
Zeitpunkt, der dazu durchgereichte Impuls geht über einen Trafo zum
Ausgangstransi.
(Nur) Dessen Betriebsspannung wird gesteuert von SV, Transi T2,
gesteuert non T1 und T3. Dazu bekommt SV alle 3 relevanten Spannungen an
T1 und T3.

SV ist also nicht nur Stromversorgung, sondern auch Vorsteuerung der
Phasenanschnittsteuerung.
Hier kann ich -an den Transis mittels der Vorspannungen- die
Phasenanschnittsteuerung von Hand auslösen, aber- ungeregelt.

OPV ist dabei erst mal noch nicht involviert.
Die 3 Spannungen sind also erst mal wichtig- denn die Differenz
Rohspannung/ Spannung hinter Regeltransi ist die Regelgröße.

D. h.: Erst mal muß eine Spannung da sein, die um Uce des Regeltransis
höher ist, als die niedrigste Rohspannung.
Dazu muß die Thyristorsteuerung die Thyris gezündet haben. Auch im Falle
gewünschte Ua = 0 V.

Dem ist z. Z. noch nicht so- und ich versuche zu klären, warum das so
ist.
Dazu werde ich nachher wieder messen.

***********************************

Und wieder eine Korrektur: 2 Transis sind im Schaltplan der SV-
Baugruppe und im Bestückungsplan verschieden (T2 und T3), und im Bestückungsplan sind dazu auch noch Emitter und Kollektor der beiden Transistoren vertauscht !

Die SV ist momentan scheinbar der Knackpunkt. Die Thyristor- Steuerung springt nicht
an.

Wenn ich T1 B/E kurzschließe, wird T1 C/E hochohmig. T2 ebenfalls, T3
bekommt positive Basisvorspannung über W9, C/E niederohmig- damit kann
die Steuer- Baugruppe arbeiten und zündet, allerdings mit voller Phase-
Spannung am Ausgang auf max.

C/E des Längsreglers überbrückt- ebenfalls Zündung und volle Ua.
SV- Anschlüsse 22 und 23 zusammen- ebenfalls Zündung und volle Ua.
SV- Anschlüsse 23 und 25 zusammen- ebenfalls Zündung und volle Ua, das
entspricht ja dem brücken von C/E des Längsreglers.
Anschlüsse 22 und 25 zusammen- Zündung und etwas höhere Ua.

Ich habe die Schaltpläne mit anderen Geräten verglichen, die die
Baugruppen verwenden, verglichen- die Belegungen sind identisch.

Mit der SV- Leiterplatte des 4209 springt der Phasenanschnitt an- auf
dieser ist der W15 nicht 0 (Brücke), sondern 2 MOhm, W18 ist auch größer
240 K).
D. h. T1 wird nicht voll durchgesteuert, der Phasenanschnitt hat genug
zum Starten. Aber der Regelbereich für die Ausgangsspannung ist da,
jedoch gering.

***********************************

Was auf den Platinen ist, dürfte ok sein.
Vor allem: Ich habe die Platinen vom 4209 reingesteckt- fast das
Gleiche, nur eine etwas höhere Ausgangssannung mit kleinem Regelbereich,
wenn man den Steller für Uce (SV- Platine) stark verstellt.
Der Spannungsteiler am Eingang SV ist anders.

Und die 4210 ins 4209- dort funktioniert's... ich habe nicht bis volle 3
KV hochgedreht und Strom getestet, aber 0- 2 KV ließ sich einstellen,
Anzeige Spannungs/ Strombegrenzung ging auch !

Thyris: Vorher 600V- Typen, hatte nur 500 V, es geht, bei Gelegenheit
Rücktausch. Mit allen das gleiche Ergebnis.
Elkos habe ich die wichtigsten gemessen- alle ok.
Die von dem anderen Netzteil, dem 4209, sind uralte DDR- Frolyten in
Alu- selbst die sind ok.
Die SZXe sind -bis auf eine- Versorgungs- Stabilisierungen, da kann ich
die Spannung direkt messen- alle ok.
SAYen- die meisten überprüft- nichts.
Die Transis SC237 habe ich gegen die im Schaltplan angegebenen
getauscht- auch nichts.
Hochohmige WIderstände- alle ok.

Der Fehler schein im Grundchassis zu liegen- aber bisher nichts
gefunden. Ich hatte ja schon verrückte Sachen, Lötstellen an
Leiterplatten- Fassungen gebrochen (Ursache das Herausziehen der
Leiterplatten)... aber auch nicht. - Bisher überprüfte Verdrahtung ok.

Aber ich geb' nicht auf... manchmal sieht man eben nur den Wald vor
lauter Bäumen nicht. AM Ziffernvoltmeter habe ich Monate gesessen- jetzt
messe ich damit in dem Netzteil- das Digi hat einen 2 KV- Bereich, mit 5
Stellen, da brauche ich nicht die Meßbereiche umstellen.

***********************************

Die Unterlagen der netten Tanja habe ich.
Ja, die hat das Raupenhaus- Zeug.

Ansonsten habe ich als Papyrus 3KV- 4209, sowie  Niederspannungsgeräte-
Betriebsanleitungen 3203, 3205, 3217,bei 3217 sogar 2 unterschiedliche
Ausführungen: alt mit KD607/ neu mit KD502.

Als Scan auch noch 301, TG13 und TG20-6.

Alles Betriebsanleitungen, 4205 ohne Schaltplan.
Die BA 4210 habe ich sogar von Statron als Scan bekommen.

ALLE BA- Hefte haben nur eine rudimentäre Beschreibung, sie sind...
...OHNE Reparaturhinweise.
Es gibt scheinbar nur BA- Hefte.

Die Fremd- Scans sind alle grenzwertig.
Ich werde diese Scans alle aufarbeiten.
Die eigenen sind hochaufgelöst, der Aufwand ist geringer.

Ein 4209 ist ok, das 4210 in Arbeit, auf dem Werkstattisch ist ein 3202
im Einsatz, und in der Werkstatt stehen noch 3 weitere Statron-
Netzgeräte, 3203 und 3217.
Die 6 Geräte werden für ein größeres Projekt bald alle gebraucht, darum
bin da dran.

Wie man sieht, kann man sich an so einem Gerät schon richtig seilen-
einfach sind die Kisten nicht.

Aber immerhin die Besten für ihren Zweck, ich hatte sie einst bei RFT in
Gang- unverwüstlich, kaum kaputtzubekommen.
Die Drehspulmeßwerke sind mir lieber, als unruhig flackernde
Ziffernanzeigen.
Die Geräte die ich habe, sind nun mal alt, und erst jetzt, nach 40- 50
Jahren und teilweise hartem Betrieb, reparaturbedürftig.

Wie geschrieben, wer so ein Gerät in Gang hat, und Unterlagen benötigt-
ich bin nebenbei am Aufarbeiten.

Als Anhang: Endbearbeitetes PDF des korrigierten und restaurierten 4210-
Gesamtstromlaufplans als 2- seitiges Poster, eine Seite den weißen Rand
abschneiden, die Schaltung läßt sich perfekt zusammenkleben.
Kann ich auch in 4 Seiten machen oder zum Tapezieren in Wandgröße.
:-)

***********************************

Nochmal überprüft, sogar mal mit Russenthyris probiert, es hätte
durchaus sein können, der Phasenanschnitt ist im 4210 etwas
schwachbrüstiger, als in den anderen Geräten dieser Bestückung.
4205 (1,5 KV) und 4209 (3 KV) haben 2 Transis in der Ausgangsstufe der
Steuer- Baugruppe, 4210 (600 V) hat nur 1 Transi anstelle 2 in
Darlington).

In den Original- Unterlagen des 4210 ist dasüberhaupt nicht dokumentiert
!
Jedoch in der Unterlage des 4205 ist es aber gedruckt- und sogar ein
Hinweis auf das andereModellt: "(T5) entfällt bei 4210" !!!

Fehler in den Unterlagen fand ich jede Menge- die Transi- Bezeichnungen
und Anschlüsse des Bestuckungsplan der Steuer- Baugruppe sind
falschherum, ein Anschluß der Fassung ist falsch bezeichnet (9 statt 3),
und es gibt noch andere Fehler und undokumentierte Änderungen.

Darum der Aufwand meinerseits, die -bisher bekannten- Unterlagen zu
revidieren.

Mehr oder weniger verständlich- die Statron- Netzteile standen in
Werkstätten und Industrieanlagen, und wurden zur Reparatur einfach an
Statron geschickt.

Wie auch immer, 1 Transi reicht aber mit allen Thyris zum Zünden, und
der Phasenanschnitt- (Steuer-) Eingang ist auch recht empfindlich- da
reicht schon der Innenwiderstand des Hand- Voltmeters, da kann ich nur
mit dem hochohmigen Ziffernvoltmeter ran, sonst springt die Steuerung
sofort an.

Es ist ein Fehler in der Bereitstellung der Regelgrößen für die
Regelungen- viel Luft habe ich jetzt nicht, denn da ist außerhalb der
Baugruppen recht wenig Material in Gang.

***********************************

So- heute abend etwas Zeit gehabt...noch etwas gegrübelt- und- Fehler
gefunden.
:-)

Die fetten Ladeelkos hatte ich vor einigen Tagen geprüft,
und die zeigten in etwa ihre Kapazität.
Aber... mein Kondensatorenprüfer prüft nur die Kapazität, und leider
nicht mit Nennspannung- und da lag der Hase im Pfeffer.

An einem Punkt über der Prüfspannung (ca. 40- 60 V) macht einer der Elkos nicht
mehr mit, aber keinen Reststrom oder Kurzschluß, sondern...
...spannungsabhängiger Kapazitätsverlust.
Damit sind natürlich beide Elkos wirkungslos.

Das würde beim normalen Netzteil eine schön verbrummte Spannung geben.
Hier ist aber ein Ausgangs- Papierkondensator drin, der Ausgang ist
unbelastet, und am Ausgang eines Hochspannungsnetzteils schließt man
auch keinen Oszi an.

Die Statrons haben eine Schutzschaltung mit einem Thyristor auf der
Treiber- Platine- der reagiert auf eine schnelle Spannungsänderung,
zündet, und zieht den Phasenanschnitt sofort herunter.
Nach einer Zeit läßt der Schutz- Thyristor wieder los- und läßt die
Phasenanschnitt- Thyristoren wieder anlaufen, die Regelung soll dann mit
Strombegrenzung arbeiten- gerade eine plötzliche Hochlast (Kurzschluß)
ist ja der Schutzfall.
So ist das vorgesehen.

Die nehazu ungesiebte Spannung am Gleichrichter sieht der Thyristor nun als
Spannungseinbruch.
Rrrrrums ! Macht er dicht.

Und dann... passiert das Gleiche immer wieder, der Thyristor läßt locker, die
Spannung steigt, der Elko sagt ab, pulsierende Gleichspannung,
abfallender Halbsinus- und der Thyristor schlägt wieder zu.

Offensichtlich reicht die Spannungsänderung "nach unten" aus, um die
Löschung des Thyristors zu gestatten. Sind ja auch noch Widerstände als Last
parallel.

Diese Vorgänge bewirkten, daß noch etwas Spannung aufgebaut wird, sowie
das geringe "Wackeln" der Spannung um 1 V im ca. 1 Sekunden- Takt,
bedingt durch die Erholzeit, und Trägheit infolge der Restkapazität bis
zum Erreichen der "Abschalt- Spannung" des Elkos.
Die Spannung steigt wahrscheinlich sogar noch höher, die Meßinstrumente
sind aber zu träge, um das anzuzeigen, auch mein Ziffernvoltmeter nicht-
ich habe zwecks ruhiger Anzeige einen Filter eingeschaltet !
Die "Abschalt- Spannung" des Elkos ist übrigens nicht konstant, weder
zeitlich, noch vom Spannungswert her. An einem anderem Netzteil etwa 20-
60 V.

Da die Platinen alle in Ordnung sind, nützte auch das Platinentauschen
nichts- die Schutzschaltung funktionierte ordnungsgemäß.
Ohne Schutzthyri hätte das Netzgerät vielleicht funktioniert, irgendwann
wäre eine verbrummte Ausgangsspannung unter Last aufgefallen- aber ich
hatte aufgrung gleichen Fehlers mit einer gleichen Platine von 4209
keinen Anlaß, die Schutzschaltung auszubauen- ich rechnete auch nicht
mit der schnellen Reaktionszeit.

Ich habe jetzt 220µF/ 350 V angehängt- das ist aber nur zum Testen. Ich
muß vernünftige Elkos besorgen, 500 µF/ 350 V gehören rein.

Wenn ein vernünftiger Elkosatz drin ist, werde ich die Spannungsangaben
erstellen können, die in keiner Statron- Unterlage vorhanden sind, die
Meßpunkte sind beim 4210 auch ohne Leiterplatten- Verlängerungsadapter
mit Hirschmann- Klemmen erreichbar.

***********************************

Nachdem ich das 4210 nun wieder in Gang gebracht habe... habe ich auch
den Technik- Chef von Statron erreichen können !

Von diesem hatte ich vor Jahren die 4210 Unterlagen bekommen, sein Name
steht drauf.
Und der kennt die Geräte alle in- und auswendig. Den Fehler, den ich
hatte, natürlich auch.

Auweia, da habe ich Tage vergeigt, eine Frage zur rechten Zeit hätte das Problem
geklärt...

Nun ja- betreffs der Anfrage nach Unterlagen für die Hochspannunsgeräte
bekam ich eine verblüffende Antwort:

Es gibt keine Reparaturunterlagen !

Grund: Es gibt lediglich Prüf- und Einstellanweisungen für mit
speziellen Arbeitsplätzen mit Spannungsbereitstellungen und geeigneten
Meßgeräten, die nicht jede Werkstatt zur Verfügung hat.

Die Fehlersuche wird -so wie ich das machen mußte- durch getrennte
Inbetriebnahme der Komponenten durchgeführt.
Klar- die Komparatoren mit den OPV regeln nichts, wenn der
Phasenanschnitt nicht schon mal die -vorgeregelte- Rohspannung zur
Verfügung stellt.


Den Phasenanschnitt kann man auch problemlos eigenständig zünden.

Dabei muß berücksichtigt werden, daß der Phasenanschnitt soviel
Regelreserve besitzt, daß es gefährlich werden könnte, die Siebkette ist
"auf Kante genäht", ohne Vorregelung und ohne Last steht an der
Siebkette weit mehr Spannung an, als diese verträgt !!!

Ich habe dazu die Speisespannung des Gesamtgerätes am Stelltrafo reduziert, es ging ja nur um den Test, ob der Phasenanschnitt überhaupt anspringt.

Eine Hand- Einstellung der Rohspannung
an der Gleichrichtung sollte möglich sein,  das konnte ich nicht realisieren, der Phansenanschnitt ist sehr empfindlich.
Es war aber auch nicht unbedingt nötig.

Für ein in Betrieb befindliches Gerät gibt es einige Einstellungen, die
im Plan vom 4205, 1,5KV- Gerät, Schaltplan bei Elektrotanya, per Hand
reingekritzelt wurden- die sind kaum zu entziffern, der Statron- Techniker nannte mir die Werte- die passen dort gar nicht- es sind die vom 3KV- Gerät !
Da hatte vermutlich ein 4209- Besitzer mangels der Unterlagen eben die
vom 4205 verwendet- die Hochspannungsgeräte sind ja mit den gleichen
Baugruppen -mit geringen Bestückungsänderungen- versehen.

Ich werde mit dem Techniker in Kontakt bleiben, und die weitergehenden
Messungen für den Reparaturfall erarbeiten- zumindest für die
beschriebenen Geräte 4205, 4208, 4209, 4210.

Warum ich mir den Aufwand mache ? Ich habe ein größeres Projekt vor, bei
dem 6 solcher Geräte in Gang gebracht werden, und die müssen zuverlässig
funktionieren.

Wer solche Statron- Geräte nutzt, oder zu reparieren hat, möge mich
kontaktieren, es wird etwas dauern, weil ich zur Zeit, und auch arbeitsmäßig, immer unterwegs bin/ sein werde, aber ich habe mobiles Internet.

Später werde ich die erarbeiteten Unterlagen der Allgemeinheit zur
Verfügung stellen, so ist es bereits mit dem Statron- Techniker
verabredet.

Fotoserie


Frontseite


Draufsicht


Unterseite


Steckbaugruppen: Treiber, Regelverstärker, Stromversorgung, Steuerbaustein.


Die Ladeelkos


Ladeelkos ausgebaut

 

Siebelkos durch moderne Elkos ersetzt

 


Funktioniert wieder, Spannungskonstanter Betrieb, eingestellt 300 V



Stromkonstanter Betrieb, eingestellt 100 mA


Die Frontplattenschrauben neu verzinkt


Zum Schluß die feststellbaren Original-  Feintriebe, da hatte ich noch welche in Reserve.


Das Statron 4210 ist fertig.

Die beiden Aufkleber "Danger" und "Power" sind albern.
Aber sie sehen sauber aus. Ich laß' sie dran.
Na ja... es gibt Schlimmeres.

:-)





.

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

.

Seite
Menü
News
Seite
Menü
News

Neue Seiten- Geänderte Seiten

14.07.2024 In "Edi's Specials"/  die Seite "Special 2024- Superhet nach Hans Sutaner wiederentdeckt" erstellt.

01.07.2024 In "Oktober 2023-Der erste Sender von 1923 sendet wieder !" /  die Seite "
Alle historischen Schaltungsquellen und Analyse" erstellt.

04.06.2024: In "Restauration Meßtechnik" die Seite "Restauration Funkwerk Köpenick "Normal- Oszillograph" OG2-1, DDR 1953" hinzugefügt.

02.06.2024: In "Restaurationsberichte" die Seite "Restauration Schaub Kongreß Super, ein sog. Einbereichssuperhet von 1938" hinzugefügt.

27.04.2024: In "Wissenssammlung" die Seite "Messungen an alten Kondensatoren"
hinzugefügt.

23.02.2024 Seite "Specials- 2024- Und wieder ein Jubiläum- 100 Jahre Kaskodeschaltung" erstellt

07.02.2024 In "Oktober 2023-Der erste Sender von 1923 sendet wieder !" /  die Seite "Rechercheergebnisse NACH dem Projekt und Korrektur historischer Darstellungen" erstellt.

26.12.2023 Seite "Weihnachten 2023- Bauanleitung für ein von einem Funkpionier vor 100 Jahren entwickeltes Längst- und Langwellen- Radio" erstellt

26.11.2022 In "Edi's Specials"/  die Seite "Edi EM11 UG- Magisches Auge mit Uranglas" erstellt.

 

 

 

Seite
Menü
News

Powered by CMSimple | Template by CMSimple | Login